UniKey Enveloper Tool: Difference between revisions

From SecuTech Wiki
Jump to navigationJump to search
No edit summary
No edit summary
Line 71: Line 71:
== Guide Mode interface components and layout  ==
== Guide Mode interface components and layout  ==


<br>
<br>  


[[Image:UniKey_Envelop_Tool_Pic02.jpg]]<br>  
[[Image:UniKey_Envelop_Tool_Pic02.jpg]]<br>  
Line 93: Line 93:
'''''Menu bar'''''  
'''''Menu bar'''''  


<br>




<br>


[[Image:UniKey_Envelop_Tool_Pic03.jpg]]
[[Image:UniKey_Envelop_Tool_Pic03.jpg]]


<br>  
<br>  
Line 107: Line 109:
'''''Protect menu'''''  
'''''Protect menu'''''  


<br>




''<br>''
[[Image:UniKey_Envelop_Tool_Pic04.jpg]]
[[Image:UniKey_Envelop_Tool_Pic04.jpg]]


Line 120: Line 122:
'''''View menu'''''  
'''''View menu'''''  


<br>
<br>  
 
 


[[Image:UniKey_Envelop_Tool_Pic05.jpg]]
[[Image:UniKey_Envelop_Tool_Pic05.jpg]]
Line 130: Line 134:
<br>  
<br>  


'''''About menu'''''<br>
'''''About menu'''''<br>  


''
''


[[Image:UniKey_Envelop_Tool_Pic06.jpg]]
[[Image:UniKey_Envelop_Tool_Pic06.jpg]]
Line 140: Line 148:
''• About: Provides information about Enveloper, such as version etc.<br>''  
''• About: Provides information about Enveloper, such as version etc.<br>''  


<br>


'''''Drop down list'''''<br>  
'''''Drop down list'''''<br>  


• Drop down list: Helps you select the project which you are going to edit from the same solution  
• Drop down list: Helps you select the project which you are going to edit from the same solution  
Line 147: Line 158:
<br>  
<br>  


'''''Protect button'''''</i>
'''''Protect button'''''
 


<br>


• Clicking on the Protection button: Lets you execute protection for your software by enveloper  
• Clicking on the Protection button: Lets you execute protection for your software by enveloper  
Line 161: Line 172:
<br>For example, if you are currently using professional mode, the working mode button will display Guide Mode, and by clicking on it, the system will toggle to Guide mode, and vice versa.  
<br>For example, if you are currently using professional mode, the working mode button will display Guide Mode, and by clicking on it, the system will toggle to Guide mode, and vice versa.  


<br>  
<br>


== Professional Mode interface and layout<br>  ==
== Professional Mode interface and layout<br>  ==

Revision as of 20:24, 11 April 2012



About UniKey Enveloper

UniKey Enveloper is a powerful tool that can protect your software from illegal usage. It secures your application by wrapping it in a shell.


UniKey Enveloper provides the fastest and easiest automatic software solution to protect your executables, DLLs and data used in and by your application. The greatest advantage of usin g UniKey Enveloper is that you do not have to access the source code of your application.


By running this tool and setting up the protect parameters, you can wrap your software in a secure shield, which can guarantee that no one else without your permission can use this protected software. Meanwhile, when you are using Enveloper to protect your application, an anti-debug mechanism will automatically be added to you application, rendering pirates who want to use reverse engineering method to hack your software impossible.


What Can Be Protected ?


You can apply protection directly to data files, executables and DLLs.


The protection can be applied by the Enveloper directly which is easy and fast to implement.


Protection Procedure

To protect software by using UniKey Enveloper is very simple; users can perform it by following the procedure described below:


1. Start UniKey Enveloper in the SDK\Utilities\Enveloper\UniKey Envelop Tool


2. Specify the program which you want to protect


3. Set protection parameters for the program and execute


4. Send your protected software together with the corresponding UniKey to your customer


The structure of the UniKey Enveloper Interface

The enveloper is stored in UniKey_SDK\Utilities\Enveloper\UniKey Enveloper Utility folder.

To launch enveloper, double click on the Enveloper icon, and the enveloper control panel will appear.




The UniKey Enveloper provides two different interface modes (Guide Mode and Professional Mode) to accommodate different user preferences. Users can switch between the two modes by clicking on the button in the upper right corner of the main panel or alternatively select the working mode from the View menu in the menu bar.


Guide Mode is specially designed for those beginner users, as the system will guide users step by step to configure their desired settings. It is very easy to use.


Professional mode is suitable for advanced users who are familiar with the UniKey system. You can modify settings by selecting the specific parameters from the Solution window.


By default, when you start the Enveloper, the main interface will be displayed in Professional mode, and after you create a solution, the panel will change to guide mode, shown in the following picture.


Guide Mode interface components and layout




The guide mode interface consists of:


1) menu bar

2) input window. In Guide mode, the input window lets you specify options step by step, guided by system.

3) progress navigation bar. The Progress navigation bar is a user friendly tool that guides users to finish configurations and indicates the user’s current progress. The users progress will be highlighted by a yellow box.

4) output window. The output window displays information about errors and the Envelopers running status.


Menu bar





• New Solution: Create a new software protecting solution
• Close Solution: Close the currently open solution
• Add a Project: Add a project to the currently open solution
• Open: Open a previous solution
• Save: Save all configurations of the currently open solution, to the current working directory
• Save as: Save to a specified location
• Import: Open the configuration file created by a previous version of enveloper
• Exit: Closes the Enveloper program


Protect menu




• Protect Project: Execute enveloper to shield your selected project
• Protect All Projects: Execute enveloper to shield all the projects in the current solution


View menu




• Guide Mode: Switch the Enveloper interface to guide mode layout, which is meant for beginner users
• Professional Mode: Switch the Enveloper interface to professional mode layout
• Solution Window: Choose whether to display the Solution window or not
• Output Window: Choose whether to display the Output window or not


About menu




• About: Provides information about Enveloper, such as version etc.


Drop down list


• Drop down list: Helps you select the project which you are going to edit from the same solution


Protect button


• Clicking on the Protection button: Lets you execute protection for your software by enveloper


Working mode switch button

• Working mode switch button: Helps you switch between the two different types of working mode (guide mode and professional mode) conveniently.


For example, if you are currently using professional mode, the working mode button will display Guide Mode, and by clicking on it, the system will toggle to Guide mode, and vice versa.


Professional Mode interface and layout

The professional mode consists of the following four components:


1) menu bar.

2) solution window.

3) input window.

4) output window.


The function and content of 1) menu bar and 4) output window in professional mode are the same as Guide mode, for more details about these sections please refer to the above section.


Solution Window
The solution window displays every project in the solution, and all the steps for setting each project in a tree view. By click on the settings in the solution window, you can easily access every setting.

Input Window
For every setting, the input window provides an interface for users to specify the setting desired. Users can use the solution window to configure the content in the input window.

Enveloper Settings

Source File              

The executable file or .DLL file to be protected


Data File                    

Data file associated with the source file


Output Location          

The destination folder where the protected file will be saved


Password                    

UniKey has two-level security permissions by using four passwords. Users can login as user by providing the first two passwords or as a vendor by providing all four passwords. To use the enveloper to protect software, you must input the four passwords.


'Module setting's          


Lets you assign a module number for your protected software. When the specified module number in the UniKey device is enabled, the protected software can be started/accessed


Time settings              

The UniKey time model has 16 time modules. You can bind you software to a specific time module, and indicate the expiration date or duration time


HID settings        

The UniKey’s unique identity number. You can bind your software to this number to ensure that only when the corresponding UniKey is presented, the protected software can run.


Background settings    

When the protected software starts working, the software will start checking the UniKey device every Loop Time (defined by you). This function can ensure that the UniKey device must be connected to the computer while the protected software is been used.


Debugger settings        

This function lets you protect your software from been cracked by using debugger techniques.


• Basic
• Advanced
• Kernel
• IDE
• Virtual PC


Network settings

UniKey PRO, Time and Drive provide software protection in a Local network environment. When this function is enabled the UniKey device will search through the network. The software will work properly if the right device is detected.


To use the Network function, the following parameters need to be configured:


Working Mode
• Network Only: The protected software will only search for the UniKey through the network
• Local->Network: The protected software will search for the UniKey from the local computer firstly, and if it is not found, the software will search the network
• Network->Local: The protected software will search for the UniKey from network first, and if it is not found, the software will search the local computer


Access Mode
• Per Thread: Protected software can logon to the UniKey many times
• Per Process: Protected software can logon to the UniKey only once
• Per IP: For each IP address, only one instance of the protected software can be launched


Searching Mode
• Direct Only: The protected software will search for the UniKey from the specified IP address only
• Direct->Broadcast: The protected software will search for the UniKey from the specified IP address, and if the UniKey cannot be found, the software will search for the UniKey from the entire network automatically
• Broadcast->Direct: The protected software will search for the UniKey from the entire network, and if the UniKey cannot be found, the software will find the UniKey from the specified IP address


Server IP: The Server IP address where the UniKey is connected


Server Port: The port number used for the connection between server and client


Time Out: Defines the timeout value of the communication between the server and clients


DotNet Settings

This function lets you protect your .Net application according to the operating system in which the .Net application works. It can generate protected applications for both X86 and X64 platforms.


Start Dialog Settings

Enable or disable the start screen display function


Warning Message

Define the warning and error output message

Protect Software using Enveloper

Enveloper protects software without changing the source code. At any time you can start enveloper to adjust settings and perform upgrades to your protected software.


Guide Mode

Double click on the Enveloper icon to start Enveloper and the enveloper main panel will appear.


File:UniKey Envelop Tool Pic08.jpg


New Solution

Create a solution by selecting the “File→New Solution” from the menu bar, and the following window will appear.




Select the UniKey Type which you are going to use to protect your software. Enter the name and description for your new created solution, and select the destination folder where the new solution file will be stored. Click on the OK button to confirm your settings. The window will close and the Enveloper main panel will switch to Guide mode automatically, as shown in the following picture.



The system will create a new project called [your solution name]_1 automatically.


Select Files

Click on the Add button to add your software which you want to protect to the current project. A File Editor window will pop up.



This button next to the Source File input box allows you to locate the software you want to protect, or input the software location directly. If there is some data files associated with your software, you can protect these data files by clicking on the “Add” button to add them into data files box.


The similar button next to the Output Location input box allows you specify where the protected software will be stored or input the destination folder directly. Click on the “OK” button to finish setting the protected software file settings.


You can add one or more executable or DLL files to each project. To add another program, please repeat the operation described above, you can add zero or more data files associated with one executable or DLL file.

Device Settings


Device settings consist of:


• Password
• Bind mode
• Bind time
• Bind HID
• Bind SID
• Background check


To use a UniKey device to protect your software, you must input the correct password to the UniKey device. Click on the password setting button, and the interface will switch to the password setting interface. To enable an option, just check the option box following the option. When the colour of a check mark  changes to green, the option is enabled. For more settings, click on the Setting button to switch to the setting interface.


The options with a shaded check mark  means that the corresponding settings are not enabled.


Use this icon in the progress navigation bar to switch to Device Settings


Password Settings


Enter the correct four passwords, and then click the guide mode button to switch back to guide mode.


To simplify user operations the system provides some default settings, therefore if you want to use the default settings, you can check the option box to enable the function directly.


For example, the system will automatically enable background checks by default.


System Settings


After you have finished with the device settings, click on this icon to get into the system settings interface.


System settings


System settings consists of:


• Start Dialog
• Network
• Anti-Debugger
• Warning Message


You can choose to enable and configure any protection function by checking the corresponding tick box and clicking on the setting button.


If you enable the network function, you must click on the corresponding setting button to set the server address, please note that only UniKey Pro, Time and Drive support this function.



Click on this icon to go to the next step.


Build Project


The input window displays all the details about your solution. You can check your configuration from this window, and click on the Protect button to execute your software protection with the Enveloper tool.


Professional Mode

Professional mode provides an interface to set the UniKey hardware and system configuration for advanced users. To switch to the professional mode, after creating a new solution, click on the Professional Mode button.



After the encryption operation has completed, the “Encryption successful” will show in the output window.


Solution


By clicking on the parameters in the solution window, you can start to configure the parameters in the input window directly.

After finishing all configurations, click on the protect button to execute protection.


Protect without dongle(Remote Update)

Consider the situation that UniKey devices have been distributed to end users and the users want to renew the software, such as update the latest version, the traditional way is that users need to send back their dongle back to software vendors, which cost shipping fees and waste time.

Our Enveloper provides application protection without dongle connection, to reduce logistic cost.


To start protect application without dongle, switch Unikey Enveloper to professional mode.


Uncheck the Insert Device Mode operation, for the rest configurations please follow the Protect Software using Enveloper instruction.


As there is no UniKey device connect to enveloper, if you want bind your application to a specified HID, the only way to do that is to select bind HID with Selected HID, and then select the specified HID value from the database where you saved the value before you sent the UniKey to the end users.(Later version will be added HID management part)



UniKey Enveloper is a tool to provide application protection, if you want to a update license remotely, please use the “Update Generator Tool”, the general procedure is:


1. Double click on the Generator Icon


a. In "Basic Settings", set the correct password for the client's dongle
b. In "Basic Settings", check the "Bind Update Tag", and enter the current tag of our client's dongle.
c. In "Basic Settings", also check the "New Update Tag" and enter a new Tag, so that after your client runs the updater, his dongle´s tag will change (and because the update is bound to the old tag - item b - he will only be able to update his dongle once).
d. In "Module Settings", set the value of Module 0 to the count limit (if desired), and check the "Auto decrement" box


2. In "UPT File", click "Generate" and choose the destination for the upt2 file.


3. Send the upt2 file and the "Updater" tool to your client, and ask him to run the Updater tool with the upt2 file with the dongle connected.


4. Send the enveloped software to your client, together with the dlls.


For further UniKey Generator instructions please refer to UniKey Generator part in the UniKey tools manual.